01.03.2015

Скрипт для проверки наличия USB-модема на RouterOS

Понадобился скрипт, определяющий наличие USB-модема, подключенного к Mikrotik. Присылает на почту название модема и его серийник. Хорошо бы допилить скрипт до отправки уровня сигнала и количества денег на счете, но мои модемы не дают доступа к своему меню - надо шить.



:log info "Starting Modem Info Script...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:local mname [/system resource usb get 1 value-name=name];
:local mnumber [/system resource usb get 1 value-name=serial-number];
:local smtpserv [:resolve "smtp.mail.ru"];
:local Eaccount "mail@mail.ru";
:local pass "your_password";
:log info "Collecting Information";
:delay 5;
:log info "Sending Information via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes \
subject=("$sysname Modem Information (" . [/system clock get date] . ")") \
body=("$sysname Modem.\nTime and Date stamp: " . [/system clock get time] . " " . \
[/system clock get date] . "\nModem $mname, SN: $mnumber");
:log info "Modem Info Complete!";


Комментариев нет:

Отправить комментарий