01.09.2022

Помочь развитию блога

Написание постов требует огромного количества времени на эксперименты, подготовку стендов и собственно написание поста.

Вы можете замотивировать автора на написание интересных и полезных постов и помочь ему денежкой. Переведите на мой Яндекс кошелек хоть сто рублей - вам незаметно, а мне приятно.

Внести свой вклад в развитие блога вы можете с помощью Яндекс.Денег или с банковской карты

21.01.2018

CIS Benchmarks

CIS Benchmarks - набор гайдов и лучших практик для обеспечения безопасности различных информационных систем. Начиная от браузеров и десктопных  Windows, через RedHat и VMWare до отдельных сервисов типа Apache и оборудования от Cisco и других вендоров.

Рекомендую ознакомиться!

https://learn.cisecurity.org/benchmarks

https://drive.google.com/drive/folders/1JKMMLBrbzPC_oeTfd-UvdNyIdD94GY7I

Как этим пользоваться на примере Windows 7

[book] Подборка книг по системному администрированию. Январь 2018


Первый пост в этом году. 

За новогодние каникулы накопилось много информации. И первое, чем хотелось бы поделиться - замечательная подбрка книг. Почти все они прилетели из классного Telegram канала для сетевиков - Network Warrior. Сам ещё не прочитал ни одной из них (за исключением, пожалуй нескольких глав из предыдущих изданий UNIX and Linux System Administration Handbook, постера и книжки для детей про K8s)

21.12.2017

Проверка пропускной способности канала на Mikrotik

Скрипт для Mikrotik RouterOS, тестирующий пропускную способность канала и записывающий результат в файл. Перед запуском создать файл isp-quality.txt и указать IP своего btest сервера в ipbandswtestserver

https://github.com/devi1/RouterOS-scripts/tree/master/bandwidth%20test


:local txAvg 0
:local rxAvg 0
:local ipbandswtestserver your.btest.server.ip
:local btuser btest
:local btpwd btest
:local ts [/system clock get time]
:local ContentsFile [/file get isp-quality.txt contents]
:local ds [/system clock get date]

:set ts ([:pick $ts 0 2].[:pick $ts 3 5].[:pick $ts 6 8])
:set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])

tool bandwidth-test protocol=tcp direction=transmit address=$ipbandswtestserver duration=5s do={
:set txAvg ($"tx-total-average" / 1048576 );
}

tool bandwidth-test protocol=tcp direction=receive address=$ipbandswtestserver duration=5s do={
:set rxAvg ($"rx-total-average" / 1048576 );
}

/file set isp-quality.txt contents="$ContentsFile\n$ds-$ts tx: $txAvg Mbps - rx: $rxAvg Mbps"


20.11.2017

Мikrotik RouterOS Configuration Management с помощью скриптов и какой-то там матери

Жизненный цикл сети часто переживает закономерный рост. В это время начинают появляться десятки и сотни устройств, конфигурация которых однотипна. Например, это могут быть маршрутизаторы в филиалах, которые имеют одинаковые настройки и отличаются только IP адресами, паролями на VPN и Wi-Fi. Внесение даже незначительных изменений на десяток устройств потребует значительного времени и концентрации.

Для управления сотнями и тысячами устройств весь цивилизованный мир уже давно использует специальные системы менеджмента конфигураций: Ansible, Chef, Puppet. Каждая из них имеет свои плюсы и минусы.


Но для десяти-двадцати устройств не каждый захочет выделять отдельный сервер с такой системой. Поэтому в ход идут скрипты, SSH, FTP и куча матов, когда всё это поделие роняет сразу все филиалы.

Видео для привлечения внимания
Это визуализация запросов от роутеров к системе, о которой идет речь в этом посте.